error messages and not working

You need help with guitarix, ask here

error messages and not working

Postby akaawol » Fri Mar 31, 2017 11:02 am

Been looking at all the stuff in the help here and still can't find a solution.
First the error messages when opening:
[18:53:25] system init *** failed to lock memory: Cannot allocate memory
[18:53:25] system init *** failed to lock memory: Cannot allocate memory
[18:53:29] PitchTracker *** error creating realtime thread - tuner not started

Followed the thread viewtopic.php?f=3&t=4759 but no success there.
Jack Audio has the RT flashing but configuring the patches is something I don't understand.

I'm using a Startech usb external sound card. Using GNOME ALSA Mixer I can hear my guitar over the speakers, just not getting any effect from guitarix.

Next I might add that in the sound settings (the one on the task bar) normal shows app that are accessing the sound. example if I play a video in chrome it would say that chrome is in use. With guitarix open it's not listed as having access to the sound.
User avatar
akaawol
 
Posts: 3
Joined: Fri Mar 31, 2017 10:50 am

Re: error messages and not working

Postby brummer10 » Sat Apr 01, 2017 2:11 am

Hi

The first step you need is to set up jack with realtime privileges, check out how it goes here:
http://www.jackaudio.org/faq/linux_rt_config.html

then learn a bit about jack, what it does and how to use it:
http://libremusicproduction.com/article ... arted-jack

So, when you get guitarix started without error messages, you can go here to a nice introduction of guitarix, and how to use it:
http://libremusicproduction.com/article ... d-guitarix

I know, it's a little learning step, but at least, it's all the same for all pro audio apps in linux, so, when you get one running, you can run them all.
Don't hesitate to ask questions when you need help in the steps between.

regards
hermann
User avatar
brummer10
Site Admin
 
Posts: 699
Joined: Thu Mar 26, 2009 6:57 pm

Re: error messages and not working

Postby akaawol » Sat Apr 01, 2017 9:58 am

Screenshot from 2017-04-01 17-51-10.png
Screenshot from 2017-04-01 17-51-10.png (41 KiB) Viewed 92 times

I'm ever closer I believe, However that system playback (the only sound out listed) is the little speaker inside the mac mini. Not my usb from startech. I can hear the effects just now but can't find a way to add the sound card to jack.
User avatar
akaawol
 
Posts: 3
Joined: Fri Mar 31, 2017 10:50 am

Re: error messages and not working

Postby brummer10 » Sat Apr 01, 2017 11:31 am

Good to hear you make progress.

So, plug your usb soundcard in, and stop jack. Now go to the qjackctl setup widget, select settings -> advanced and go to input device. Press the little hook there and select your usb card from the poping up list. Do the same for output device.
Most often you'll have hints like Capture / Playback next to multiple entry's for your device, take them into account.

PS: for USb soundcards, often a Periode/Buffer of 3 fits better then 2.

Don't connect gx_head_fx to pulse_jack_source!
User avatar
brummer10
Site Admin
 
Posts: 699
Joined: Thu Mar 26, 2009 6:57 pm

Re: error messages and not working

Postby akaawol » Sat Apr 01, 2017 12:04 pm

Screenshot from 2017-04-01 19-57-56.png
Screenshot from 2017-04-01 19-57-56.png (100.73 KiB) Viewed 89 times

I had thought to try that. The Usb listed don't seem to connect to the actual device.
I've basically tried every possible configuration I could think of here.
User avatar
akaawol
 
Posts: 3
Joined: Fri Mar 31, 2017 10:50 am

Re: error messages and not working

Postby brummer10 » Sat Apr 01, 2017 12:11 pm

Post the output from
Code: Select all
lsusb
User avatar
brummer10
Site Admin
 
Posts: 699
Joined: Thu Mar 26, 2009 6:57 pm


Return to need help with guitarix

Who is online

Users browsing this forum: No registered users and 1 guest

cron